Apr 14

[原]安装Eclipse 多国语言包 晴

linuxing , 13:57 , 编程 » Java , 评论(0) , 引用(0) , 阅读(98874) , Via 本站原创 | |
    Eclipse 从3.2.1版本之后,官方就不再提供语言包支持。3.2.1之后的版本,都由另一个子项目Eclipse Babel Project 提供。这里以简体中文为例,基于URL 式插件安装方法来说明一下。

一、Babel 项目
在Eclipse 3.2.1时,Eclipse 官网是提供多国语言包的,请见:这里。我在另一篇日志 [原]Eclipse 3.6.2 JFace 对话框显示中文 中也描述过如何使用一个单独的语言包,这里不再细说。若使用Eclipse 3.2.1的朋友,请自行上网搜索。

而自3.2.1后,多国语言的支持,都已交由Eclipse Babel Project 子项目提供。
Eclipse Babel Project 项目官网为:http://babel.eclipse.org/
当前最新版本是0.8.1。

二、选择插件安装的方式
Eclipse 的插件有几种安装方式:
1、links 方式
这方式安装复杂些,但插件易于安装和卸载。
以语言包来说,你可以先从Babel 项目直接下载所需要的语言包Babel Language Pack Zips:
地址:http://www.eclipse.org/babel/downloads.php
然后,参考Eclipse插件安装几种方式及使用说明 一文来配置links目录及相关的文件。这里不再细说。

2、URL 式插件安装法
这方法是接借助Eclipse 提供的联机安装功能进行,简单而轻松。
各版本对应更新地址为:
引用
Babel Update Sites - 0.8.1
Babel Language Pack Update Site for Helios
http://download.eclipse.org/technology/babel/update-site/R0.8.1/helios

Babel Language Pack Update Site for Galileo
http://download.eclipse.org/technology/babel/update-site/R0.8.1/galileo

Babel Language Pack Update Site for Ganymede
http://download.eclipse.org/technology/babel/update-site/R0.8.1/ganymede

Babel Language Pack Update Site for Europa
http://download.eclipse.org/technology/babel/update-site/R0.8.1/europa

然后,打开Eclipse,然后点击Help->Install New Software… 弹出的窗口中的Work With中点击Add,然后添加相应Eclipse版本的Babel更新地址(http://download.eclipse.org/technology/babel/update-site/R0.8.1/helios):
点击在新窗口中浏览此图片
※ 我使用的是Helios,即3.6的Eclipse。Eclipse 3.5/3.4/3.3 则分别对应为Galileo/Ganymede/Europa。上述的地址不能直接方法,只能通过Eclipse 联机安装。

Eclipse会自动上服务器上寻找各种语言包,时间比较漫长,一直显示“Pending”,只要网络是连通的,请耐心等待。直到所有的语言包列表显示出来(不过很多包的翻译进度并不是100%,没办法,自愿性质的项目都这样)。然后选择您需要的语言包即可:
点击在新窗口中浏览此图片

点击“Next”开始安装,会提示一些协议确认信息等,安装完毕后,记得重启Eclipse。
以下是加入简体中文包的界面:
点击在新窗口中浏览此图片

三、切换英文
如果觉得汉化后的环境不适应,或其他原因,可在启动执行文件eclipse.exe后加入-nl en_US 参数,以切换回英文环境。
例如,修改启动图标中的设定:
点击在新窗口中浏览此图片
Tags:
发表评论
表情
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
打开HTML
打开UBB
打开表情
隐藏
记住我
昵称   密码   游客无需密码
网址   电邮   [注册]