Mar 28

[原]发布ExtMail 1.0.8/ Extman 1.0.0安装及升级rpm 晴

linuxing , 16:12 , 网络服务 » 邮件系统 , 评论(3) , 引用(0) , 阅读(16985) , Via 本站原创 | |
配合社区发布Extmail 1.0.8和Extman 1.0.0版本的RPM包。

3ext修正版:
修正对某些来信人列表时显示为空的错误,见这里:
http://www.extmail.org/forum/thread-10179-1-1.html
http://www.extmail.org/forum/thread-10189-1-1.html
使用yum直接升级即可,执行前建议先运行yum clean all 操作。

2ext修正版:
有朋友报1.0.8-1ext版的安装包有问题,见这里:
http://www.extmail.org/forum/thread-10176-1-1.html
遇到该问题的朋友,请使用1.0.8-2ext升级,执行:

yum clean all
yum update extsuite*

如果您还没安装1.0.8-1ext版本,该操作会直接升级到1.0.8-2ext。

注意事项:
引用
1、由于Extmail公布了开发版本,故跳过了Extmail 1.0.6和1.0.7(最后一位是单数表示开发版),开发版考虑到实际的使用人群,不提供rpm安装包了;
2、由于Extman修改了版本号,上一个版本是0.2.5,跳到了1.0.0,rpm版本使用相同的版本信息;
3、该更新已经测试过extmail的1.0.5升级到1.0.8,以及extman从0.2.5升级到1.0.0版本,也支持EMOS 1.3.0直接升级到目前的版本;
4、该包已经过测试,但未能确保万一,升级前请备份配置文件webmail.cf和webman.cf,以及个性化信息;
5、若使用yum升级时提示网络超时等问题,可手动把rpm包放到下面的目录后重试:
/var/cache/yum/EMOS-update/packages/
6、由于服务器升级,原使用ftp提供的下载改由http方式提供;
7、改动了rpm设定文件,不会覆盖原来webmail.cf和webman.cf ;
8、修改1ext版本中,没有加入sender_restrictions的问题。

升级方式:
1、修改/etc/yum.repos.d/EMOS-Update.repo文件
把原来:
引用
[EMOS-OS]
name=EMOS - OS
baseurl=ftp://emos:linuxfly@emos.linuxfly.org/1.3/os/$basearch/
gpgcheck=0
priority=0
protect=0

[EMOS-update]
name=EMOS - Update
baseurl=ftp://emos:linuxfly@emos.linuxfly.org/1.3/updates/$basearch/
gpgcheck=0
priority=0
protect=0

改为:
引用
[EMOS-OS]
name=EMOS - OS
baseurl=http://download.linuxfly.org/emos/1.3/os/$basearch/
gpgcheck=0
priority=0
protect=0

[EMOS-update]
name=EMOS - Update
baseurl=http://download.linuxfly.org/emos/1.3/updates/$basearch/
gpgcheck=0
priority=0
protect=0

2、执行升级

yum install yum-plugin-fastestmirror
yum update extsuite*

※ 推荐先安装yum-plugin-fastestmirror,然后再升级。

安装包本地下载:
extsuite-webmail-1.0.8-2ext.i386.rpm

extsuite-webman-1.0.0-1ext.i386.rpm


关于Extmail 1.0.8和Extman 1.0.0的详细更新信息,请见这里:
发布Extmail Webmail 1.0.8 稳定版
发布Extmail 后台Extman 1.0.0 稳定版
Tags:
Ahchen
2009/06/13 16:59
[root@mail yum.repos.d]# yum update extsuite*
Loading "fastestmirror" plugin
Setting up Update Process
Setting up repositories
http://download.linuxfly.org/emos/1.3/os/i386/repodata/repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.
Cannot open/read repomd.xml file for repository: EMOS-OS
failure: repodata/repomd.xml from EMOS-OS: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from EMOS-OS: [Errno 256] No more mirrors to try.
[root@mail yum.repos.d]#
linuxing 回复于 2009/06/15 09:58
ISP那边download.linuxfly.org的域名解析有问题,重新设置了映射,等待刷新后就可以了。
808kkk1984
2009/05/07 17:47
我用 extmail 1.10的压缩包覆盖了yum升级的1.08的extmail ,打开extmail页面报错,版主可以有什么方法可以解决不!
现在用压缩包直接覆盖 ,报错,请问该修改什么地方啊!
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

提示太少,我不知道从哪下手!webmail。cf 保留原来的,也不行
apache 系统日志maillog也没有什么消息
linuxing 回复于 2009/05/07 21:03
对不起,还没有看1.10的版本,暂时没有解决办法。看这两天能否提供新的升级包吧。
EMOS
2009/04/15 16:53
你知道EMOS什么时候出新版本吗?
linuxing 回复于 2009/04/16 10:57
暂时计划是下一版本是2.x的,基于Centos 5.x,但时间上还说不准,待工作比较空闲的时候尽快完成吧。
不过,我有个想法,就是不再提供单独的EMOS光盘,而只提供yum升级源和安装配置脚本,这样以后Centos更新,就不会导致必须升级EMOS的问题了。但这个设计重新设计安装配置脚本的问题,工作不是马上可以完成的。
分页: 1/1 第一页 1 最后页
发表评论
表情
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
打开HTML
打开UBB
打开表情
隐藏
记住我
昵称   密码   游客无需密码
网址   电邮   [注册]